Aller au contenu
admseb

Problèmes de performances réseaux

Messages recommandés

Bonjour,

j'ai des problèmes de performances réseaux entre mon serveur linux (Centos) et un poste client.

 

Mon collègue a fait un petit script basique (p:\test.cmd) qui effectue 3 copies de c:\test\test1(pc)  vers \\srvlinux\transfert

 

1ère série de tests (antivirus désactivé):

 

-      Test1 -> Copie en utilisant le hostname du serveur
-      Test2 -> Copie par l’intermédiaire de l’@IP
-      Test3 -> Copie par l’intermédiaire d’un lecteur mappé
Dans les 3 cas, les temps sont similaires (résultat sous c:\tmp\latence.txt du poste exécutant).
Par contre, grosses différences entre serveur logiciel (windows 12 R2) et le poste client, les temps de copie passant du simple au double.
 
Il semble donc bien qu’il y ait un ralentissement réseau en sortie (entrée) des PC. A moins qu’il s’agisse d’un élément physique défaillant, mais logiquement, tous les PC ne seraient pas impactés.

 

2ème série de test (antivirus désactivé) :

Nous avons effectué le test sur 4 PC différents ainsi que sur les serveurs Citrix et voici les temps observés :

- Mme toto : 29s (sur la station d'accueil) pour chacun des 3 tests
- M. dupont: 30s avec connexion réseau( sur la station d'accueil) et 20s sur un adaptateur USB ETHERNET.
- PC de test : 11s
- Mon PC : 8s.
- Serveur CITRIX 1 ; 9s
- Serveur CITRIX2 : 8s.

A noter que le PC de M. dupont, le pc de test et le mien sont dans le même bureau .

 

Si quelqu'un a une idée, je suis preneur, merci d'avance.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

Plusieurs cause à tes soucis:

  • Performance disque en lecture
  • Type carte réseau
  • Pilote carte réseau
  • Système d'exploitation
  • Qualité du câble réseau utilisé

Cela fait autant d’élément qui justifie les différences de temps de copie.

A note que ta station d’accueil ne propose peut-être pas de port Gigabit ...

 

Tu peux essayer de clearer un peu les trames. Je m'explique:

Les PC sont de plus en plus bavard (encore plus avec Windows 10) Tu peux essayer de faire en sorte que ça discute moins ;)

 

tiens nous au courant !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @MathTek :

 

  • Performance disque en lecture :  possible mais ils sont tous SSD INTEL ou INTEGRAL
  • Type carte réseau :  possible aussi car M. Dupont possède une Surface 
  • Pilote carte réseau : je les ai mis à jour.
  • Système d'exploitation : Windows 7 sur le mien, les autres en Windows 10, je recherche sur le net des optimisations à faire sur W10.
  • Qualité du câble réseau utilisé : j'ai mis la même marque sur les 3 PC ( M. dupont, le pc de test et le mien qui sont dans le même bureau)

Les PC sont de plus en plus bavard (encore plus avec Windows 10) Tu peux essayer de faire en sorte que ça discute moins  : je suis en recherches comme expliqué plus haut.

 

Un grand merci en tout cas, je vous tiens au courant :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour Windows 10 je penses qu'il y a plus a faire, avec toutes les applications qui tournent en fond, elles sont toutes susceptible de parler. Autre fait: sur les systèmes l'IPv6 est activer par défaut. Si tu ne l'utilise pas, désactive le, ça génère du broadcast pour contacter un serveur pour rien. 

Partager ce message


Lien à poster
Partager sur d’autres sites

@admseb Est ce que ca te dérangerai de me filer le script et les fichiers qui sont copiés pour le test (en privé ou via Skype)?

J'ai aussi des lenteurs réseaux chez un client, et ca me permettrai de comparer les temps de copies avec ce que tu annonces pour tes essais.

 

Et qui sait, si je trouve le problème, peut être que tu seras dans le même cas et que ca t'aidera à le résoudre!

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

As tu vérifié les versions de protocoles utilisées lors des copies ?

 

Genre SMB1/2/3 ?

 

Est-ce le transfert en lui même qui est plus lent, ou son démarrage ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Pour tester les performances réseau, j'utilise l'outil iperf https://iperf.fr/fr/iperf-download.php

cela permet de tester le réseau et uniquement le réseau puisque les données ne sont pas écrites sur le disque

une machine en mode serveur (iperf.exe -s) et une autre en mode client (iperf.exe -c +autres option)

 

Après on choisit les réglages selon ce qu'on souhaite mesurer (bande passante, gigue, perte de paquet, taille de paquet, UDP ou TCP ...)

 

Une fois qu'on connait son réseau on peut chercher du coté des machines ce qui pourrait ralentir.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, fizzlager a dit :

Bonjour,

Pour tester les performances réseau, j'utilise l'outil iperf https://iperf.fr/fr/iperf-download.php

cela permet de tester le réseau et uniquement le réseau puisque les données ne sont pas écrites sur le disque

une machine en mode serveur (iperf.exe -s) et une autre en mode client (iperf.exe -c +autres option)

 

Après on choisit les réglages selon ce qu'on souhaite mesurer (bande passante, gigue, perte de paquet, taille de paquet, UDP ou TCP ...)

 

Une fois qu'on connait son réseau on peut chercher du coté des machines ce qui pourrait ralentir.

 

@fizzlager  : Merci pour l'outil, je vais regarder.

 

Il y a 8 heures, Exelsis a dit :

Ton serveur Linux est une vm ?

 

@Exelsis : j'ai oublié de préciser en effet. Mon serveur Linux est une Vm et mes serveurs Citrix sont des serveurs physiques.

Partager ce message


Lien à poster
Partager sur d’autres sites

As tu pris le temps de tester sur les portables branchés au reseau en direct ?

Les perfs d'une station d'accueil ont jamais ete delires :-)

 

As tu testé avec un tres gros fichier pour voir le taux de transfert que Windows annonce une fois stabilisé ?

Partager ce message


Lien à poster
Partager sur d’autres sites

As tu tester le débit de copie entre ta vm Linux et une autre vm sur le même hôte ? As tu vérifier que les tools vmware ou hyperbole sont bien installés ? Tente d ajouter une carte réseau avec un tire pilote sur to. Linux

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 02/03/2018 à 22:29, Steph69 a dit :

As tu pris le temps de tester sur les portables branchés au reseau en direct ?

Les perfs d'une station d'accueil ont jamais ete delires :-)

=> @Steph69

Oui je l'ai fais :

- M. dupont: 30s avec connexion réseau( sur la station d'accueil) et 20s sur un adaptateur USB ETHERNET.

As tu testé avec un tres gros fichier pour voir le taux de transfert que Windows annonce une fois stabilisé ?

=> oui (2Go),

 

Le 02/03/2018 à 22:37, Exelsis a dit :

As tu tester le débit de copie entre ta vm Linux et une autre vm sur le même hôte ? As tu vérifier que les tools vmware ou hyperbole sont bien installés ? Tente d ajouter une carte réseau avec un tire pilote sur to. Linux

=> @Exelsis : oui , je suis dans les 13s entre ma Vm Linux et Vm Windows 2012R2 . Tools installés.

J'ai testé aussi la carte, j'ai gagné 2s.

 

Actuellement, je teste avec iperf que @fizzlager m'a conseillé.

 

J'ai remonté une vm sur mon PC en Virtualbox en CentOs (même version que mon serveur lent)

Je n'arrive pas faire communiquer le côté serveur (Vm linux VB) au côté client (Pc de test ou serveur Windows)

Il me dit connection refused.

 

J'ai désactivé le firewall des 2 côtés.. je cherche. Sinon Cela fonctionne bien entre les serveurs Windows et/ou de postes à postes.

 

Exemple avec un serveur appli et mon pc :

 

SRVACR :
C:\Iperf>iperf3.exe -c 192.1.1.77 -i 1
Connecting to host 192.1.1.77, port 5201
[  4] local 192.1.1.95 port 14290 connected to 192.1.1.77 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec   110 MBytes   925 Mbits/sec
[  4]   1.00-2.00   sec   110 MBytes   926 Mbits/sec
[  4]   2.00-3.00   sec   110 MBytes   926 Mbits/sec
[  4]   3.00-4.00   sec   109 MBytes   916 Mbits/sec
[  4]   4.00-5.00   sec   109 MBytes   916 Mbits/sec
[  4]   5.00-6.00   sec   110 MBytes   918 Mbits/sec
[  4]   6.00-7.00   sec   110 MBytes   918 Mbits/sec
[  4]   7.00-8.00   sec   110 MBytes   921 Mbits/sec
[  4]   8.00-9.00   sec   110 MBytes   918 Mbits/sec
[  4]   9.00-10.00  sec   109 MBytes   917 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  1.07 GBytes   920 Mbits/sec                  sender
[  4]   0.00-10.00  sec  1.07 GBytes   920 Mbits/sec  

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×