Jump to content
eric.drd

Svchost

Recommended Posts

Réponse tardive

 

heu, j'en sais rien, de toute façon le souci ne se pose plus vu qu'en avril 2014, Microsoft arrêt les mises à jours pour XP.

Donc à quoi bon ?

 Bonne journée

Share this post


Link to post
Share on other sites

Respect Ducke ! As tu la page ou qui propose le lien de téléchargement ? j'aimerais avoir plus d'infos en tout cas je met ce fixit de coté !!

 

 

je comprend pas trop ce que tu souhaites MultPlex, je n'ai rien à part le lien que j'ai donné sur le Fix it et l'autre qui aide à en télécharger d'autre suivant les divers problèmes rencontrés.

 

 

Il y a un article sur Blogmotion qui traite de ce problème : ICI

 

La page Web de Microsoft qui propose ce fix it est la page de la KB suivante : KB971058 (Trouvé sur l'article de Blogmotion).

Share this post


Link to post
Share on other sites

vous direz peut etre que je vois le mal partout mais tous mes clients sur xp ont eu/ont le problème. Du coup comme ils entendent de la bouche de Madame Michu "qu'xp va s'arrêter début 2014" ils finissent par se poser sérieusement la question du renouvellement. Je trouve que ce bug tombe au final pas trop mal pour Microsoft.... :rolleyes:

Share this post


Link to post
Share on other sites

J'ai fait un essai ce matin en installant Win XP PRO SP3 OEM Officiel sur une VM. Une fois l'installation terminée, les pilotes installés et l'activation faite, j'active le téléchargement auto des MAJ. Et là, rien à faire, Svchost prend 100 % de l'UC au bout de quelques minutes....

 

EDIT 1 : La machine est toujours à 100 % de temps processeur sur svchost après 1h40 d'uptime.

 

J'ai fait un autre essai en utilisant le site de Windows updates après install de IE8 et d'une mise à jour cumulative sur un clone de cette VM.

 

La procédure est longue. On dirait qu'il y a 2 mises à jour ou l'audit de deux mises à jour qui posent problème et provoquent la charge à 100 % du processeur ; la situation se débloque au bout de 5 à 10 minutes à chaque fois. Une fois ces deux mises à jour passées, tout rentre dans l'ordre... je vais identifier ces 2 mises à jours.

 

Toujours avec un clone de cette VM, j'ai fait les mises à jour via WSUS Offline et ensuite pas de problèmes en activant les maj auto, par contre l'installation auto de la kb 905474 (Windows Genuine Advantage Notification) fait monter scvhost a 100 % pendant 5 minutes

 

EDIT 2 : L'essai que j'ai fait ce matin après install de IE8 + kb de mise à jour cumulative ne marche plus quand je le rereproduis à partir du même snapshot de la même VM. Windows Update m'affiche l'erreur 0X8024D001...

 

J'arrette là pour aujourd'hui...

Share this post


Link to post
Share on other sites

comme je l'écrivais plus haut je trouve ce bug des plus supects... il faudrait savoir par exemple en faisant les maj par un cd de wsus offline update le problème se pose aussi (si ce n'est pas le cas ca peut etre une piste pour l'utiliser en curatif par la suite) je manque de temps pour essayer en ce moment et en plus j'ai un gros pb de débit pour refaire un cd à cause d'un soucis sur ma ligne tél...

Share this post


Link to post
Share on other sites

j'ai un peu avancé sur mes problèmes de Windows Update sur un Windows XP Pro SP3 OEM brut d'installation...

 

Voici mes 2 procédures fonctionnelles à l'heure ou j'écris ce message :

 

Méthode avec WSUS Offline (pour gagner beaucoup de temps) :

 

Il faut desactiver les mises à jour automatiques de suite puis reboot du pc ( le mieu est de ne pas les activer du tout à l'installation).

 

On lance les MAJ Windows via un WSUS Offline à jour.

 

Il vaut mieux installer cette maj manuellement KB905474 ( windows Genuine Advantage Notification ) pour gagner pas mal de temps car il évite le bug scvhost à 100 % durant l'installation sur le site Windows Update.

 

Ensuite,il faut allez sur le site de Windows Update, il faut faire les mises à jour et relancer Windows puis relancer Windows Update pour vérifier qu'il ne reste pas de mises à jour. Vous pouvez ensuite réactiver les Maj Auto et ça sera bon.

 

 

Methode Classique :

 

On peu le faire sans passer par Wsus Offline, dans ce cas il faut également désactiver les mises à jour auto ( ou plutot ne pas les activer lors de l'installation de Windows XP , et ensuite installer manuellement IE8 (lien) et l'agent Windows Update 3.0 : WindowsUpdateAgent30-x86.exe.

 

Il vaut mieux installer cette maj manuellement KB905474 ( windows Genuine Advantage Notification ) pour gagner pas mal de temps car il évite le bug scvhost à 100 % durant l'installation sur le site Windows Update.

 

On lance le site Windows Update et là il ne faut pas etre pressé non plus....Svchost monte à 100% de temps processeur. Ca finira par marcher. On relance Windows puis le site de Windows Update pour vérifier qu'il ne reste pas de mises à jour. Vous pouvez ensuite réactiver les Maj Auto et ça sera bon.

Share this post


Link to post
Share on other sites

tu as avancé ? j'ai eu pas mal de cas et la méthode bien que non miraculeuse à l'air de bien fonctionner.

 

J'ai même eu un cas ou Windows update était desactivé et malgrès cela svchost à 100 %. Si ensuite j'allais dans les services pour desactivé le service windows update le process svchost repassait à 0 % de charge CPU.

 

Pour résoudre le problème, j'ai reactivé le service windows update et j'ai fait la procédure que j'avais ecrite et c'était à nouveau ok.

Share this post


Link to post
Share on other sites

×
×
  • Create New...