Jump to content
Sign in to follow this  
mmonzon

Changement de serveur

Recommended Posts

Bonjour tout le monde,

Je travaille actuellement chez un de mes clients et j'ai quelque interrogations.

Je vous explique la situation :

 

Mon client est un expert comptable qui dispose de 3 sites (A , B et C)

Sur le site A (le site principal), j'ai une vingtaine de pc , 3 copieurs , quelques imprimantes ainsi que les serveurs.

Sur le site B, j'ai 6 pc, un copieur et une imprimante.

Sur le site C, j'ai 2 pc, un copieur et une imprimante.

Chaque site est relié via un vpn au site A (SDSL 2M et ADSL pour la résilience en mode dégradé)

 

Il y a un mois CEGID a changé les serveurs, par un nouveau.

Les anciens serveurs étaient des windows server 2003. Un était contrôleur de domaine et l'autre serveur TSE.

Le nouveau serveur est un windows server 2012 R2 sur lequel est installé le rôle hyperviseur Hyper-V pilotant ainsi 3 serveurs virtuels :

-Un pour l'AD, les documents, le serveur d'impression et l'antivirus

-Un autre pour les bases de données SQL Server

-Un autre pour le rôle RDS (TSE) 

 

Avant le changement des serveurs les utilisateurs avaient chacun un bureau TSE sur lequel toutes les applications étaient installées.

Maintenant CEGID a eu des soucis à faire son installation (Problème de bureau TSE (RDS) à moitié en anglais et en francais), du coup ils ont abandonnées le principe de bureau à distance et ont décidé d'utiliser le déploiement de remoteapp publiée cachant le problème de langue.

 

Le déploiement sur le poste client se fait en passant par Panneaux de configuration\Connexions RemoteApp et Bureau à distance.

De ce fait les utilisateurs ont sur leur pc une icone par application publié et chaque lancement d'application ouvre une session sur le serveur RDS en mode remoteApp (Seule l'application est visible).Les applications telles que la suite office, l'exporer du serveur ainsi que leur applications tierses ont été publiées.

 

Ma question est simple. Est ce que le fait de passer par ces remoteapp n'utilise pas beaucoup plus de bande passante que le fait d'utiliser le bureau à distance. Car depuis que la migration a été effectuée les impressions mettent jusqu’à 20 minutes avant de sortir (surtout au niveau des sites distants) et il y a beaucoup de lenteur au niveau des applications.

 

Désolé pour la longueur du message mais je souhaitai être le plus précis possible.

 

Share this post


Link to post
Share on other sites

Salut!

 

Normalement, non, RemoteApp c'est même mieux que TSE en terme d'utilisation de bande passante.

Par contre, si le problème des impressions existe depuis le changement de serveur, je pencherais plus sur un problème avec les pilotes installés sur le serveur??

Les imprimantes ont été distribuées par une GPO?

Sinon c'est quoi ce problème de langue? L'environnement Server 2012 est en anglais totalement? Ca pue l'install foireuse ca...

Share this post


Link to post
Share on other sites

Le problème de langue c'est du style bureau en desktop, mes documents en my documents et à coté de ça d'autres éléments sont bien en français.

Ils ont refait leur installation de Windows plusieurs fois et à chaque fois le même résultat. Je pense que le problème vient de leur master d'installation qui a été modifié par Cegid. Ce qui m’énerve le plus c'est qu'ils ont camouflé ça avec les remoteapp car de cette manière on ne voit plus les éléments du système mais seulement l'application lancée.

Et cela apporte d'autre problèmes car parfois dans certaine applications il y a des fenêtres popup qui apparaissent et qui une fois minimisé se mettent dans la barre des notifications (systray) et  là en remoteapp on ne les voit plus donc on ne peux plus les récupérer. 

 

Oui les imprimantes sont distribuées par GPO.

Share this post


Link to post
Share on other sites

Pour le problème de langue, essaye de télécharger le package de langue fr dans le centre de téléchargement chez Microsoft.

Ensuite, lance sur le serveur l'outil lpksetup.

Installe le package, et regarde si ca modifie ou pas... Au pire si le package fr change rien essaye un autre pays francophone, histoire que le système le gère bien indépendamment.

Share this post


Link to post
Share on other sites

Pour les problèmes de lenteur (et freeze temporaires d'applications en RemoteApp), essaye de désactiver l'option de cache bitmap pour le clients RDS. Pour ca tu peux créer la clé "[HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\bitmapCacheSize]" avec une valeur 00000000 (en dword), en utilisant une GPO.

 

Sinon est ce que tu as essayé d'utiliser une appli en remote app, à partir d'une machine qui ne soit pas sur le domaine?

Parce que la lenteur vient peut-être d'une GPO foireuse aussi...

Share this post


Link to post
Share on other sites

Merci pour tes infos, je retourne chez ce client lundi.

Je vais tester tes différentes solutions.

J'ai appelé le fournisseur d'accès de leur ligne internet. Il va isoler les flux d'impressions, les redirigé vers les adsl de résilience.

Share this post


Link to post
Share on other sites

Merci pour tes infos, je retourne chez ce client lundi.

Je vais tester tes différentes solutions.

J'ai appelé le fournisseur d'accès de leur ligne internet. Il va isoler les flux d'impressions, les redirigé vers les adsl de résilience.

Mouai, je creuserais un peu avant moi perso. Si ca se trouve, avec un changement de pilote ca se passera mieux!!

Share this post


Link to post
Share on other sites

Un détails qui a sans doute son importance, mes applications publiées sont des work ressources.

Quelqu'un connait il quelque chose la dessus. J'ai fait quelques recherches et je n'ai rien trouvé de probant.

Share this post


Link to post
Share on other sites

Jamais entendu parlé perso... Une appli publiée c'est une appli, non??

T'es pas arrivé à repérer une coïncidence entre certaines actions et le fait que ca rame beaucoup? Des choses qui empirent ou améliorent la situation?

Sinon t'as essayé une analyse de ce qui se passe sur le réseau? Histoire de vori ce qui circule si c'est si lent que ca, c'ets peut-être qu'il y a trop de monde là dedans!!

Share this post


Link to post
Share on other sites

Pour les impressions j'ai trouvé d'ou vient la lenteur. C'est parce que cegid a installé une GPO qui installe les imprimantes directement sur le poste de l'utilisateur et qui remonte ensuite via easyprint (en imprimante redirection de 1). Dans cette configuration l'impression est très lente.

 

J'ai donc installé les imprimantes directement sur le serveur d'impression et deployé vers le TSE.

Et la plus de lenteur

Share this post


Link to post
Share on other sites

Ah, il me semblait bien qu'une GPO aurait été une cause probable! ;)
Bonne investigation...

 

Perso je trouve qu'Easy Print c'est lent, et en plus ca monte les imprimantes correctement deux fois sur trois...

 

Donc là, l'avantage, c'est que tu va pouvoir déjà dire à ton client que tu as trouvé la première lenteur, que c'est à cause de la concurrence, et facturer ;)

Pour les lenteurs avec Remote App, t'as essayé les modifis sur le registre que je t'ai donné?

Share this post


Link to post
Share on other sites

Non le client m'a demandé de ne pas solutionner le problème pour l'instant, il veut le montrer à cegid avant.

Du coup même pour l'impression, j'ai laisser la GPO, j'ai seulement ajouter en plus les imprimantes en direct sur le serveur.

Mon client veux pouvoir montrer dans quel conditions il travaille depuis la migration. 

Share this post


Link to post
Share on other sites

Et comme ca leur mettre le nez dans le merdier qu'ils ont mis en place... :D

C'est qu'une bonne chose pour toi. Quand t'arrive à pointer du doigt un problème et à le solutionner, ca montre un peu tes qualités techniques! ;p
Et un client content, c'est un client qui fait de la (bonne) pub!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...